AX2012 R2 Enterprise portal installation issues – Part 1

The last few days I have been playing around with the Enterprise Portal. I needed to setup a High Available portal and there were soms discoveries along the road.

Though I’m planning on writing some other posts on the general architecture used when installing the Enterprise Portal in a HA environment and the possible installation issues you might have, I wanted to discuss one of the smaller issues encountered.

When opening the Enterprise Portal site, you can run into the following error:

c:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LAYOUTS\ep\EPSecurityControl.ascx.cs(13): error CS0234: The type or namespace name ‘AX’ does not exist in the namespace ‘Microsoft.Dynamics’ (are you missing an assembly reference?)

You can solve this by running the Ax installer for EP installation on all of the machines in the farm. When installing, uncheck all of the checkboxes to only install the binaries.

Warning: count(): Parameter must be an array or an object that implements Countable in /customers/5/2/1/ksaelen.be/httpd.www/wordpresses/dynamicsaxblog/wp-includes/class-wp-comment-query.php on line 399

2 thoughts on “AX2012 R2 Enterprise portal installation issues – Part 1

  1. I resolve this issue by Re installing the Client and office addons, simply uninstall the client and all components of AX , Re run the setup to install the client and office addons and EP.

  2. Hi,

    I am also facing the same problem, I tried install the EP binaries from setup also but it is not solved for me. I created a public site by extending the local one.
    any other fix if you know ?

    Thanks
    Amir

Leave a Comment Yourself

Your email address will not be published. Required fields are marked *